Fruit Automaat Razzle-Dazzle -Up&Running na 1,5jaar (Toestel of techniek)

door Maurice ⌂ @, Dordrecht, 01-08-2020, 23:38 (6 dagen geleden)
Gewijzigd door Maurice, 01-08-2020, 23:45

December 2018 begaf mijn Fruit automaat het. Zie de link.
B-Rol alarm en bleef kast hangen
in “RESETTING”

De foutmelding B-Rol herkende ik wel.
Elk van de 4 Rollen heeft een index gaatje met een optisch sensor.
Deze wordt met een 5V wire-lampje aan geschenen.
Lampje stuk? Nee dat was probleem niet.

Op de ROL-Print bleken 2x 100 Ohm weerstanden van de optische
index zwaar verlopen te zijn. Ca 230 Ohm.
Alle 4 vervangen.

Nu was 1 van de rollen ook tijdens draaien vervelende brom te horen.
De overige waren geheel stil.
Nu de kast toch weer open was, pak het eens aan.
Bij stekkers omzetten verhuisde de brom mee, dus motor is verdacht, niet de sturing.
[image]

Motor gemonteerd en onderzoek wees uit dat de as van de stappen motor axiaal
Motor afdekplaat zit gelijmd.
Door met verfföhn enig te verwarmen en mes er tussen kan met dit schadevrij afemen.
Op de as de C-klem losnemen en kan anker uitgenomen worden.

Op de as binnen zijde zit een verende ring.
Meestal zit er al een extra ring tussen.
Ik heb hier een extra verende ring tussen gedaan,
zodanig dat met een minime druk op de later weer te plaatsen C-klem de as
weer speling vrij kan draaien.
Reinigen, drup olie op de as.
Zaak weer gemonteerd. :) Geruisloos weer.

Hier anker ligt links naast de motor.
[image]

Zo heb ik verder alle lampen nagezien, nodige vervangen.
Houders gereinigd etc.
Daar ik geen juiste bedradings schema heb van mijn kast een van een andere kast
gebruikt om aan mijn kast aan te passen.
Ik heb namelijk de 4 Rol versie (geen 3) en nog wat visueel andere zaken.
Enorm karwij geweest alle bedrading uit te zoeken en in schema aan te passen.

Nu kloppen alle interne bedrading, lampen, schakelaars,spoelen, muntschakelaars etc.
met mijn kast. Handig voor als er weer wat mis is.
Detail. van de lampen.
[image]

Maar met al dat gerommel begon in jan2019 in middels de kast moeilijk op te starten.
Soms duurde het wat minuten en sprong deze toch uit reset maar daarna was over met de pret.
Bij opstart Resette de kast geheel niet meer, display gaf @@@@@@@@@@@@@@@@@@@@@.

Nu had ik bij aanschaf al het reset probleem ondervonden, was de reden dat er van de kast afstand werd gedaan.
De CPU-reset is bij deze MPU-3 wat kritisch.
Maar niets hielp om de kast tot leven te brengen.
Ook eerder had ik al eens een defect geheugen gehad, had nog een hagel nieuwe en deze geplaatst, helaas.

ZAL toch niet dat er wat met de SPEL Eproms zijn!!
Dammm ik dacht altijd nog lees die een keer in , voor geval dat...
Daar deze gesoldeerd zitten ipv een voetje, zo'n To-Do ding.
Enfin, er uit en rapido inlezen.
Maar of er fouten in zitten?? Zag er allemaal in HEX wel aardig uit.
Op Internet vond ik een ROM-SET van iets andere versie met zowaar een EMULATIE programma voor WindHopeloos.
Geïnstalleerd, werkte en nu mijn ROM set in die emulator geïnstalleerd.
En daar zag ik bij opstarten de mij bekende Nederlandse tekst en werkte de kast en de emulator.
Ik kan niet de andere versie in mijn module plaatsen, er zit een 4e chip die de HEX-Code controleert middels een sleutel, logisch is immers een proff-gokkast!
En rommelen met ROMs is uit den boze.

De test ieder geval mijn ROMs zijn OK.
[image]

Voorlopig strandde hier het plezier.

Vandaag weer eens een frisse poging gewaagd.
En zoals met veel reparaties helpt het om even met rust te laten.
de MPU-3 computer weer uit de kast genomen.
[image]
[image]

Je ziet Links naast de Accu aan rechterzijde print een opsteekprint met het spel geheugen CDM6116,welke al modificatie is ipv 2x een geheugen IC.
Heb gezegd IC had ik al vervangen, echter....Had niet de steek print er af getrokken!
En zie:
[image]

IC houder gecorrodeerd.
Nieuw voetje geplaatst, pennetjes print gereinigd.
Starten.... Rollen gaan weer draaien..en Hoop Alarm geluiden??
A-ROL Error, Nu dat weer.:fir
Hé alle 4 de index lampen van de rollen branden niet.
Geen 5V na de regelaar, laat staan 15V voor de regelaar.

Regelaar 7805 wordt via de 0V door PIO e CPU geschakeld.
Toch niet wat ernstigs?

[image]

[image]

Was even wat door piepen maar bleek een soldeerfout te zijn.
De weerstand R73 zat erg hoog en maakte maar net contact met soldeer.
Kennelijk door het vele gerommel met de print was de soldering nu gebroken.
Opnieuw gesoldeerd en we hebben weer licht.

Hier soldeer al verwijderd maar je ziet de draad zit erg diep.
[image]
[image]

Er kan eindelijk weer gespeeld worden, heb ik wel gemist, even wat gokken.
Hoewel het weigeren om ook daadwerkelijk uit te keren, helaas dat weigert de kast nog altijd, van begin af aan overigens.

Is weer eens wat anders als radio, pick-up reparatie.

Oh ja.
Voor onze gokverslaafden, hier de instelling, gewoon wat dip schakelaars.
EN ondanks de CPU 6808, simpele 8 bitter, kast weet donders goed wat ie doet.
Kast is gebouwd in 1983.
[image]


Complete draad:

 RSS Feed van berichtenreeks

powered by my little forum